[[PHPめも]]

PHPからLDAP認証を行う必要があるので、OpenLDAPをインストール。

*OpenLDAPをインストール [#tc3ab555]

おそらく入れなくていいものも指定してある。

 # yum install openldap openldap-devel openldap-servers openldap-clients

*ldap関数を使用できるようにPHPを再インストール [#b82ba63f]

--with-ldap を指定してPHPを入れなおします。
「--with-ldap」を指定してPHPを入れなおします。

configure: error: Cannot find ldap libraries in /usr/lib.

とエラーが出た場合、シンボリックを張ればうまくいくかも。

 # ln -s /usr/lib64/libldap.so /usr/lib/libldap.so
 # ln -s /usr/lib64/libldap_r.so /usr/lib/libldap_r.so



トップ   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS